[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [suse-security] Problems with latest SuSE apache2-mod_php5 from SuSE update



There is a problem in PHP with mod_rewrite in the last updates.
http://bugs.php.net/bug.php?id=35059&edit=1

Last I checked, it was somewhere between "fixed" and "not fixed". I know the FreeBSD team rolled back to the handler from 4.4.0 in 4.4.1 until the issue is resolved. I also heard the PHP team released a release candidate that is supposed to fix the issue end of last week, so a final update should not be too far away.

Hope this helps some...

Bernd Hanisch wrote:
Am Mittwoch, den 23.11.2005, 10:48 +0100 schrieb suse@xxxxxxxxxxxxx:

I have encountered a problem with apache2-mod_php5-5.0.3-14.13.i586.rpm on SuSE 9.3.

After installing the following mod_rewrite directive does not work anymore:

RewriteRule ^(.*)(index|content)\.html myscript.php [PT]


The script is no longer executed, but a empty response of (I think) type x-httpd-php is sent back. Rolling back to apache2-mod_php5-5.0.3-14.11.i586.rpm fixes that issuse.


i got the same problem with php4. error.log shows following messages:

------------------------------
[notice] child pid 8975 exit signal Segmentation fault (11)
-----------------------------

i have additional eaccelerator running. maybe the problem depends from
this tool. can't test it atm.

Greetings

Bernd Hanisch



Best regards,
Johannes Weberhofer


--


|---------------------------------
|  weberhofer GmbH               | Johannes Weberhofer
|  information technologies, Austria
|
|  phone : +43 (0)1 5454421 0    | email: office@xxxxxxxxxxxxx
|  fax   : +43 (0)1 5454421 19   | web  : http://weberhofer.at
|  mobile: +43 (0)699 11998315
|----------------------------------------------------------->>





--
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here