[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[USN-3720-1] python-cryptography vulnerability



==========================================================================
Ubuntu Security Notice USN-3720-1
July 23, 2018

python-cryptography vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS

Summary:

python-cryptography could be made to expose sensitive information
if it received a specially crafted input.

Software Description:
- python-cryptography: Cryptography Python library

Details:

It was discovered that python-cryptography incorrectly handled certain
inputs. An attacker could possibly use this to get access to sensitive
information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
  python-cryptography             2.1.4-1ubuntu1.2
  python3-cryptography            2.1.4-1ubuntu1.2

In general, a standard system update will make all the necessary
changes.

References:
  https://usn.ubuntu.com/usn/usn-3720-1
  CVE-2018-10903

Package Information:
  https://launchpad.net/ubuntu/+source/python-cryptography/2.1.4-1ubuntu1.2

Attachment: signature.asc
Description: This is a digitally signed message part

-- 
ubuntu-security-announce mailing list
ubuntu-security-announce@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce