[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: procmail again



libd.so.1 is the sharefuzz getenv() hooker which just returns big buffers.
i no longer have a redhat 7.1 machine and that information is little over 
12 months old therefore someone with a rh 7.1 system please send in your 
results!
-nd

On Sat, 18 Oct 2003 Valdis.Kletnieks@xxxxxx wrote:

> On Sat, 18 Oct 2003 17:31:35 PDT, ned <nd@xxxxxxxxxxxxxxxx>  said:
> > can't reproduce this on anything other than redhat 7.1 although procmail 
> > will segfault when a ctrl-c is passed on mandrake.
> > procmail has a very obvious signal handling problem.
> 
> RedHat 7.1 shipped procmail 3.14.
> 
> Current is 3.22.  I don't have a 3.14 handy, but there's at least 3 things I've
> spotted in the HISTORY file that may be applicable and explain why you can't
> reproduce it on other systems.
> 
> 1) Does the system have a /etc/procmailrc, and if so, what's in it?  There's a
> fix for LASTFOLDER getting set on '?' tests incorrectly, but triggering that bug
> would require at least one procmailrc file being read (and $HOME/.procmailrc isn't
> available according to the output).
> 
> 2) What is this 'LD_PRELOAD=./libd.so.1', and are you positive that it's not
> the cause of the problem?  Is the problem reproducible without preloading your
> own libraries?
> 
> 3) It's a *LOT* easier to comment if the gdb output includes a 'where', as that
> will do a stack backtrace and give us a HUGE hint as to where the problem lies.
> 
> 
> 
> 

-- 
http://felinemenace.org/~nd