[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[suse-security] Issues with pptpd



Hi,

I'm experiencing some weird issues with pptpd:
The pptp server has an external interface with a routeable IP and an internal interface with 10.x.x.x IP where clients should connect to from our wlan and get assigned routeable IP's as well. pptpd is configured to listen on the internal 10.x.x.x address and accepts incoming calls fine, but some clients can never successfully establish a connection. I cant isolate the problem to a specific group of clients though - after a reboot (rcpptpd restart doesn't change anything) win98/ME/XP clients can connect, after the next restart only 98/XP, then only ME and so forth. I'm really getting annoyed with that stuff - latest version which works for me now is the one in Debian 3.0 which is ancient.

I've had a tcpdump running and it showed some really weird traffic from pppd. Everytime a client couldnt establish a connection pppd used the external routeable IP as source IP for its packets - although ps awx and debug/dump show that it gets the proper local (10.x.x.x) IP address specified on the command line.

The system is running 9.1 Pro with the latest updates as of 2 hours ago. I think I had it working before on a system running either 9.0 or 9.1 without any updates, but I cant remember exactly and thanks to maxtors QA department I cant check it anymore since the hdd is dead....

Would be nice to get some clues how to get it working reliable again.

Regards,

Thomas

--
Check the headers for your unsubscription address
For additional commands, e-mail: suse-security-help@xxxxxxxx
Security-related bug reports go to security@xxxxxxx, not here