[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

UNIRAS Brief - 304/04 -Gentoo Linux Security Advisory - Horde-IMP: Input validation vulnerability



 
-----BEGIN PGP SIGNED MESSAGE-----

- ----------------------------------------------------------------------------------
   UNIRAS (UK Govt CERT) Briefing Notice - 304/04 dated 17.06.04  Time: 15:55  
  UNIRAS is part of NISCC (National Infrastructure Security Co-ordination Centre)
- ---------------------------------------------------------------------------------- 
  UNIRAS material is also available from its website at www.uniras.gov.uk and
         Information about NISCC is available from www.niscc.gov.uk
- ----------------------------------------------------------------------------------

Title
=====

Gentoo Linux Security Advisory - Horde-IMP: Input validation vulnerability


Detail
====== 

Horde-IMP fails to properly sanitize email messages that contain malicious HTML 
or script code.






- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200406-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Horde-IMP: Input validation vulnerability
      Date: June 16, 2004
      Bugs: #53862
        ID: 200406-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An input validation vulnerability has been discovered in Horde-IMP.

Background
==========

Horde-IMP is the Internet Messaging Program. It is written in PHP and provides 
webmail access to IMAP and POP3 accounts.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /   Vulnerable   /                  Unaffected
    -------------------------------------------------------------------
  1  net-www/horde-imp       <= 3.2.3                         >= 3.2.4

Description
===========

Horde-IMP fails to properly sanitize email messages that contain malicious HTML 
or script code.

Impact
======

By enticing a user to read a specially crafted e-mail, an attacker can execute 
arbitrary scripts running in the context of the victim's browser. This could 
lead to a compromise of the user's webmail account, cookie theft, etc.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Horde-IMP users should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=horde-imp-3.2.4"
    # emerge ">=horde-imp-3.2.4"

References
==========

  [ 1 ] Bugtraq Announcement
        http://www.securityfocus.com/bid/10501

Availability
============

This GLSA and any updates to it are available for viewing at the Gentoo 
Security Website:

     http://security.gentoo.org/glsa/glsa-200406-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality 
and security of our users machines is of utmost importance to us. Any 
security concerns should be addressed to security@xxxxxxxxxx or alternatively, 
you may file a bug at http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

- ----------------------------------------------------------------------------------

For additional information or assistance, please contact the HELP Desk by 
telephone or Not Protectively Marked information may be sent via 
EMail to: uniras@xxxxxxxxxxxx

Office Hours:
Mon - Fri: 08:30 - 17:00 Hrs
Tel: +44 (0) 20 7821 1330 Ext 4511
Fax: +44 (0) 20 7821 1686

Outside of Office Hours:
On Call Duty Officer:
Tel: +44 (0) 20 7821 1330 and follow the prompts

- ----------------------------------------------------------------------------------
UNIRAS wishes to acknowledge the contributions of Gentoo for the information 
contained in this Briefing. 
- ----------------------------------------------------------------------------------
This Briefing contains the information released by the original author. Some 
of the information may have changed since it was released. If the vulnerability 
affects you, it may be prudent to retrieve the advisory from the canonical site 
to ensure that you receive the most current information concerning that problem.

Reference to any specific commercial product, process, or service by trade 
name, trademark manufacturer, or otherwise, does not constitute or imply 
its endorsement, recommendation, or favouring by UNIRAS or NISCC.  The views 
and opinions of authors expressed within this notice shall not be used for 
advertising or product endorsement purposes.

Neither UNIRAS or NISCC shall also accept responsibility for any errors 
or omissions contained within this briefing notice. In particular, they shall 
not be liable for any loss or damage whatsoever, arising from or in connection 
with the usage of information contained within this notice.

UNIRAS is a member of the Forum of Incident Response and Security Teams (FIRST) 
and has contacts with other international Incident Response Teams (IRTs) in 
order to foster cooperation and coordination in incident prevention, to prompt 
rapid reaction to incidents, and to promote information sharing amongst its 
members and the community at large. 
- ----------------------------------------------------------------------------------
<End of UNIRAS Briefing>

-----BEGIN PGP SIGNATURE-----
Version: PGP 8.0

iQCVAwUBQNGvuYpao72zK539AQExMAQAmR4iE0FXfN+gSt0kaOEd2pCMzt71o9ua
UZy4VqsIpC4evNOr0cX7hwVbchSO6oqOJp3/coDfKAnuPT5McL/ZToG+04HTHBpU
Lj3W8L9iLeUZq3PdJpMhK4caintA2Hnuji8pSlFG729W8xPOk47wGRzN1eHhLzwf
jNJ79t3BSYU=
=tBum
-----END PGP SIGNATURE-----