[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

UNIRAS Brief - 502/05 - Three Gentoo Linux Security Advisories:



 
-----BEGIN PGP SIGNED MESSAGE-----

- ----------------------------------------------------------------------------------
   UNIRAS (UK Govt CERT) Briefing Notice - 502/05 dated 05.07.05  Time: 14:15  
  UNIRAS is part of NISCC (National Infrastructure Security Co-ordination Centre)
- ---------------------------------------------------------------------------------- 
  UNIRAS material is also available from its website at www.uniras.gov.uk and
         Information about NISCC is available from www.niscc.gov.uk
- ----------------------------------------------------------------------------------

Title
=====

Three Gentoo Linux Security Advisories:
1. GLSA 200506-17:02 - SpamAssassin 3, Vipul's Razor: Denial of Service
                       vulnerability
2. GLSA 200507-03 - phpBB: Arbitrary command execution
3. GLSA 200507-02 - WordPress: Multiple vulnerabilities

Detail
====== 

1. Sascha Lucas discovered that with certain malformed headers it was still
possible to crash Vipul's Razor.

2. Ron van Daal discovered that phpBB contains a vulnerability in the
highlighting code.

3. James Bercegay of the GulfTech Security Research Team discovered that
WordPress insufficiently checks data passed to the XML-RPC server. He
also discovered that WordPress has several cross-site scripting and
full path disclosure vulnerabilities.



1.



- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory [UPDATE]               GLSA 200506-17:02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: SpamAssassin 3, Vipul's Razor: Denial of Service
            vulnerability
      Date: June 21, 2005
   Updated: July 04, 2005
      Bugs: #94722, #95492, #96776
        ID: 200506-17:02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Update
======

Sascha Lucas discovered that with certain malformed headers it was still
possible to crash Vipul's Razor.

The updated sections appear below.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /  Vulnerable  /             Unaffected
    -------------------------------------------------------------------
  1  mail-filter/spamassassin       < 3.0.4                   >= 3.0.4
                                                               < 3.0.1
  2  mail-filter/razor              < 2.74                     >= 2.74
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Resolution
==========

All SpamAssassin users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-filter/spamassassin-3.0.4"

All Vipul's Razor users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-filter/razor-2.74"

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200506-17.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0



2.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: phpBB: Arbitrary command execution
      Date: July 04, 2005
      Bugs: #97278
        ID: 200507-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in phpBB allows a remote attacker to execute arbitrary
commands with the rights of the web server.

Background
==========

phpBB is an Open Source bulletin board package.

Affected packages
=================

    -------------------------------------------------------------------
     Package         /  Vulnerable  /                       Unaffected
    -------------------------------------------------------------------
  1  www-apps/phpBB      < 2.0.16                            >= 2.0.16

Description
===========

Ron van Daal discovered that phpBB contains a vulnerability in the
highlighting code.

Impact
======

Successful exploitation would grant an attacker unrestricted access to
the PHP exec() or system() functions, allowing the execution of
arbitrary commands with the rights of the web server.

Workaround
==========

Please follow the instructions given in the phpBB announcement.

Resolution
==========

The phpBB package is no longer supported by Gentoo Linux and has been
removed from the Portage repository, no further announcements will be
issued regarding phpBB updates. Users who wish to continue using phpBB
are advised to monitor and refer to www.phpbb.com for more information.

To continue using the Gentoo-provided phpBB package, please refer to
the Portage documentation on unmasking packages and upgrade to 2.0.16.

References
==========

  [ 1 ] phpBB Announcement
        http://www.phpbb.com/phpBB/viewtopic.php?f=14&t=302011

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0



3. 


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: WordPress: Multiple vulnerabilities
      Date: July 04, 2005
      Bugs: #97374
        ID: 200507-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

WordPress contains PHP script injection, cross-site scripting and path
disclosure vulnerabilities.

Background
==========

WordPress is a PHP and MySQL based content management and publishing
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/wordpress      < 1.5.1.3                      >= 1.5.1.3

Description
===========

James Bercegay of the GulfTech Security Research Team discovered that
WordPress insufficiently checks data passed to the XML-RPC server. He
also discovered that WordPress has several cross-site scripting and
full path disclosure vulnerabilities.

Impact
======

An attacker could use the PHP script injection vulnerabilities to
execute arbitrary PHP script commands. Furthermore the cross-site
scripting vulnerabilities could be exploited to execute arbitrary
script code in a user's browser session in context of a vulnerable
site.

Workaround
==========

There are no known workarounds at this time.

Resolution
==========

All WordPress users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/wordpress-1.5.1.3"

References
==========

  [ 1 ] CAN-2005-1921
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1921
  [ 2 ] GulfTech Advisory
        http://www.gulftech.org/?node=research&article_id=00085-06282005

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

- ----------------------------------------------------------------------------------

For additional information or assistance, please contact the HELP Desk by 
telephone or Not Protectively Marked information may be sent via 
EMail to: uniras@xxxxxxxxxxxx

Office Hours:
Mon - Fri: 08:30 - 17:00 Hrs
Tel: +44 (0) 870 487 0748 Ext 4511
Fax: +44 (0) 870 487 0749

Outside of Office Hours:
On Call Duty Officer:
Tel: +44 (0) 870 487 0748 and follow the prompts

- ----------------------------------------------------------------------------------
UNIRAS wishes to acknowledge the contributions of Gentoo for the information 
contained in this Briefing. 
- ----------------------------------------------------------------------------------
This Briefing contains the information released by the original author. Some 
of the information may have changed since it was released. If the vulnerability 
affects you, it may be prudent to retrieve the advisory from the canonical site 
to ensure that you receive the most current information concerning that problem.

Reference to any specific commercial product, process, or service by trade 
name, trademark manufacturer, or otherwise, does not constitute or imply 
its endorsement, recommendation, or favouring by UNIRAS or NISCC.  The views 
and opinions of authors expressed within this notice shall not be used for 
advertising or product endorsement purposes.

Neither UNIRAS or NISCC shall also accept responsibility for any errors 
or omissions contained within this briefing notice. In particular, they shall 
not be liable for any loss or damage whatsoever, arising from or in connection 
with the usage of information contained within this notice.

UNIRAS is a member of the Forum of Incident Response and Security Teams (FIRST) 
and has contacts with other international Incident Response Teams (IRTs) in 
order to foster cooperation and coordination in incident prevention, to prompt 
rapid reaction to incidents, and to promote information sharing amongst its 
members and the community at large. 
- ----------------------------------------------------------------------------------
<End of UNIRAS Briefing>

-----BEGIN PGP SIGNATURE-----
Version: PGP 8.0

iQCVAwUBQsqG5opao72zK539AQHBWwP8CNJAHQrcxb1O9rsy8KTXK6ucV25hlf87
vMLQsbVmNILdXERQEJoQxoJpDI2OdcDJjPtrEiSxvXLVNQGbFm5GRKrm1KjFfD7M
hxbJ2e3/Thm8je7aVMwnXYdixrReoeXRkuBqtkDZl9/mna1AJxULaFkl1BSwzIav
MCVlAAPMCic=
=e/hr
-----END PGP SIGNATURE-----


______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________