[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

UNIRAS Brief - 551/05 - Gentoo - Three Security Advisories



 
-----BEGIN PGP SIGNED MESSAGE-----

- ----------------------------------------------------------------------------------
   UNIRAS (UK Govt CERT) Briefing Notice - 551/05 dated 18.07.05  Time: 11:15  
  UNIRAS is part of NISCC (National Infrastructure Security Co-ordination Centre)
- ---------------------------------------------------------------------------------- 
  UNIRAS material is also available from its website at www.uniras.gov.uk and
         Information about NISCC is available from www.niscc.gov.uk
- ----------------------------------------------------------------------------------

Title
=====

Gentoo - Three Security Advisories:
     1.  PHP: Script injection through XML-RPC         [GLSA 200507-15]
     2.  dhcpcd: Denial of Service vulnerability       [GLSA 200507-16]
     3.  Mozilla Thunderbird: Multiple vulnerabilities [GLSA 200507-17]


Detail
====== 

Security advisory summaries:

     1.  PHP includes an XML-RPC implementation which allows remote attackers to
         execute arbitrary PHP script commands.

     2.  A vulnerability in dhcpcd may cause the dhcpcd daemon to crash

     3.  Several vulnerabilities in Mozilla Thunderbird allow attacks ranging
         from execution of script code with elevated privileges to information
         leak.


Security advisory content follows:


1.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PHP: Script injection through XML-RPC
      Date: July 15, 2005
      Bugs: #97655
        ID: 200507-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PHP includes an XML-RPC implementation which allows remote attackers to
execute arbitrary PHP script commands.

Background
==========

PHP is a general-purpose scripting language widely used to develop
web-based applications. It can run inside a web server using the
mod_php module or the CGI version of PHP, or can run stand-alone in a
CLI.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  dev-php/php       < 4.4.0                                >= 4.4.0

Description
===========

James Bercegay has discovered that the XML-RPC implementation in PHP
fails to sanitize input passed in an XML document, which is used in an
"eval()" statement.

Impact
======

A remote attacker could exploit the XML-RPC vulnerability to execute
arbitrary PHP script code by sending specially crafted XML data to
applications making use of this XML-RPC implementation.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-php/php-4.4.0"

References
==========

  [ 1 ] CAN-2005-1921
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1921

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0




2.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: dhcpcd: Denial of Service vulnerability
      Date: July 15, 2005
      Bugs: #98394
        ID: 200507-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in dhcpcd may cause the dhcpcd daemon to crash.

Background
==========

dhcpcd is a standards compliant DHCP client daemon. It requests an IP
address and other information from the DHCP server, automatically
configures the network interface, and tries to renew the lease time.

Affected packages
=================

    -------------------------------------------------------------------
     Package          /     Vulnerable     /                Unaffected
    -------------------------------------------------------------------
  1  net-misc/dhcpcd      < 1.3.22_p4-r11             >= 1.3.22_p4-r11

Description
===========

infamous42md discovered that dhcpcd can be tricked to read past the end
of the supplied DHCP buffer. As a result, this might lead to a crash of
the daemon.

Impact
======

With a malicious DHCP server an attacker could cause a Denial of
Service by crashing the DHCP client.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All dhcpcd users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/dhcpcd-1.3.22_p4-r11"

References
==========

  [ 1 ] CAN-2005-1848
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1848

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0




3.


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200507-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Mozilla Thunderbird: Multiple vulnerabilities
      Date: July 18, 2005
      Bugs: #98855
        ID: 200507-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Several vulnerabilities in Mozilla Thunderbird allow attacks ranging
from execution of script code with elevated privileges to information
leak.

Background
==========

Mozilla Thunderbird is the next-generation mail client from the Mozilla
project.

Affected packages
=================

    -------------------------------------------------------------------
     Package                  /  Vulnerable  /              Unaffected
    -------------------------------------------------------------------
  1  mozilla-thunderbird           < 1.0.5                    >= 1.0.5
  2  mozilla-thunderbird-bin       < 1.0.5                    >= 1.0.5
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

The following vulnerabilities were found and fixed in Mozilla
Thunderbird:

* "moz_bug_r_a4" and "shutdown" discovered that Thunderbird was
  improperly cloning base objects (MFSA 2005-56).

* "moz_bug_r_a4" also reported that Thunderbird was overly trusting
  contents, allowing privilege escalation via property overrides (MFSA
  2005-41, 2005-44), that it failed to validate XHTML DOM nodes
  properly (MFSA 2005-55), and that XBL scripts ran even when
  Javascript is disabled (MFSA 2005-46).

* "shutdown" discovered a possibly exploitable crash in
  InstallVersion.compareTo (MFSA 2005-50).

* Andreas Sandblad from Secunia reported that a child frame can call
  top.focus() even if the framing page comes from a different origin
  and has overridden the focus() routine (MFSA 2005-52).

* Georgi Guninski reported missing Install object instance checks in
  the native implementations of XPInstall-related JavaScript objects
  (MFSA 2005-40).

* Finally, Vladimir V. Perepelitsa discovered a memory disclosure bug
  in JavaScript's regular expression string replacement when using an
  anonymous function as the replacement argument (CAN-2005-0989 and
  MFSA 2005-33).

Impact
======

A remote attacker could craft malicious email messages that would
leverage these issues to inject and execute arbitrary script code with
elevated privileges or help in stealing information.

Workaround
==========

There are no known workarounds for all the issues at this time.

Resolution
==========

All Mozilla Thunderbird users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose
">=mail-client/mozilla-thunderbird-1.0.5"

All Mozilla Thunderbird binary users should upgrade to the latest
version:

    # emerge --sync
    # emerge --ask --oneshot --verbose
">=mail-client/mozilla-thunderbird-bin-1.0.5"

References
==========

  [ 1 ] Mozilla Foundation Security Advisories

http://www.mozilla.org/projects/security/known-vulnerabilities.html#Thunderbird
  [ 2 ] CAN-2005-0989
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0989

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200507-17.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@xxxxxxxxxx or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


- ----------------------------------------------------------------------------------

For additional information or assistance, please contact the HELP Desk by 
telephone or Not Protectively Marked information may be sent via 
EMail to: uniras@xxxxxxxxxxxx

Office Hours:
Mon - Fri: 08:30 - 17:00 Hrs
Tel: +44 (0) 870 487 0748 Ext 4511
Fax: +44 (0) 870 487 0749

Outside of Office Hours:
On Call Duty Officer:
Tel: +44 (0) 870 487 0748 and follow the prompts

- ----------------------------------------------------------------------------------
UNIRAS wishes to acknowledge the contributions of Gentoo for the information 
contained in this Briefing. 
- ----------------------------------------------------------------------------------
This Briefing contains the information released by the original author. Some 
of the information may have changed since it was released. If the vulnerability 
affects you, it may be prudent to retrieve the advisory from the canonical site 
to ensure that you receive the most current information concerning that problem.

Reference to any specific commercial product, process, or service by trade 
name, trademark manufacturer, or otherwise, does not constitute or imply 
its endorsement, recommendation, or favouring by UNIRAS or NISCC.  The views 
and opinions of authors expressed within this notice shall not be used for 
advertising or product endorsement purposes.

Neither UNIRAS or NISCC shall also accept responsibility for any errors 
or omissions contained within this briefing notice. In particular, they shall 
not be liable for any loss or damage whatsoever, arising from or in connection 
with the usage of information contained within this notice.

UNIRAS is a member of the Forum of Incident Response and Security Teams (FIRST) 
and has contacts with other international Incident Response Teams (IRTs) in 
order to foster cooperation and coordination in incident prevention, to prompt 
rapid reaction to incidents, and to promote information sharing amongst its 
members and the community at large. 
- ----------------------------------------------------------------------------------
<End of UNIRAS Briefing>

-----BEGIN PGP SIGNATURE-----
Version: PGP 8.0

iQCVAwUBQtuAQIpao72zK539AQG8TwQAmTkOc47Aff2Och0BglJBXLhPVW3Tp61x
vNs8O/1LKPKWMd1fHk3giy4KtamkVW1K4V/yMo5UqhiccuWgERG7hsgOtEejqOPJ
wYJpIHrq05VUofVreUF3igCxAdJkR6arF8zGlbjv4DhUIjrIL6D9XkjFjXa9yfmg
Sr4bC7mHpjY=
=TM9f
-----END PGP SIGNATURE-----


______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________